Задать вопрос
20 августа, 00:29

Найдите произведение всех двузначных нечетных натуральных чисел

+1
Ответы (1)
  1. 20 августа, 03:03
    0
    Программа на языке Турбо Паскаль 7.0

    Вычисляет произведения всех нечетных двухзначные чисел, введенных с клавиатуры:

    program q; / / Начало любой программы

    uses crt; / / Подключение модулей

    var a, a1, b, c: integer; / / Ввод переменных целочисленного типа

    begin / / Начало исполняемого кода

    c:=1; / / Присваиваем переменной с, хранящей произведение значения 1

    Если этого не сделать, то не сработает счетчик.

    writeln; / / Выводит надпись

    readln (a1) ; / / Считывает число, каторое вы ввели и присваевает переменной a1 его значение

    for a:=1 to a 1 do begin / / Начинает цикл от, повторяющийся нужное количества раз.

    writeln; / / Выводит надпись

    readln (b) ; / / Считывает введенное число и присваевает его значение переменной b

    if (b9) and (b mod 2=1) then c:=c*b; //Оператор условия.

    Проверяет, двузначное ли это число (больше 9 и меньше 100) и проверяет, нечетное ли оно по остатку от деления на 2

    //Если да, то присваевает с значение c*b. В первый раз это будет 1*b, во второй, то, что получилось, умножить на следующее b и т. д.

    end; / / Заканчивает цикл

    writeln ('Произведение равно: ', c) ; / / Выводит результат

    readln; //Ждет нажатия на enter

    end.//Конец программы
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите произведение всех двузначных нечетных натуральных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)