Задать вопрос
3 октября, 15:33

Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива.

var i, n:integer;

g: real;

a:array[1 ... 10] of integer;

begin

for i:=1 to 10 do

begin

write ('введите ', i,'элемент') ;

read (a[i]) ;

end;

n:=0;

for i:=1 to 10 do

n:=n+a[i];

write (n) ;

g:=n/10;

write (g) ;

end.

+2
Ответы (1)
  1. 3 октября, 18:07
    0
    У Вас всё считает правильно, но рекомендую Вам изучить вопрос: "В чем отличие между Write и Writeln?"

    При выводе добавьте "ln"
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Укажите верное описание целочисленного массива mass, состоящего из 10 элементов. Интервал значений элементов [0; 100] 1) var mass:array of integer; 2) var mass:array[1 ... 10] of integer; 3) var mass:array[0 ... 100] of integer; 4) var mass:array[0 .
Ответы (1)
Переведите программу в Free Pascal var A: Array [1 ... 100] of integer; size: integer; Even: integer; notEven: integer; begin Write ('Set size A : ') ; Read (size) ; for i:integer : = 1 to size do begin Write ('Set A[', i, ']: ') ; Read (A[i]) ; end;
Ответы (2)
Сократите эту программу program sr; var a, b, c : real; y, x, xb, xc : real; na, nb, nc: integer; function stup (x: real; n: integer) : real; var i: integer; k: real; begin k:=1; for i : = 1 to n do k : = k * x; stup : = k; end;
Ответы (1)
Какие описания массивов являются правильными с точки зрения компилятора языка Pascal? var a1: array[-1000 ... 50] of integer; const m1 = 20; m2 = m1*100; var a6: array[m1 ... m2] of - 200 ... 200; var a2: array[200 ...
Ответы (2)
Укажите правильное описание целочисленного линейного массива из 100 элементов. 1.) var B: array [1 ... 100] of real; 2.) var M: array [1 ... 100] of char; 3.) var A: array [0 ... 99] of string; 4.) var G: array [5 ... 104] of integer;
Ответы (1)