Задать вопрос
27 февраля, 21:10

Разработать программу, которая для любого х из промежутка (0; 3,14) определяет какая из двух величин больше сos (х) или tg (x)

+3
Ответы (1)
  1. 27 февраля, 23:03
    0
    Var

    x, cs, tg: real;

    begin

    Write ('Введите число в диапазоне [0 ... 3.14]: ') ;

    Readln (x) ;

    if (x 3.14) then Writeln ('Число вне диапазона')

    else begin

    cs : = cos (x) ; tg : = tan (x) ;

    if cs > tg then Writeln ('cosX > tgX')

    else if cs = tg then Writeln ('cosX = tgX')

    else Writeln ('cosX < tgX')

    end

    end.

    Тестовое решение:

    Введите число в диапазоне [0 ... 3.14]: 1.58

    cosX > tgX
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать программу, которая для любого х из промежутка (0; 3,14) определяет какая из двух величин больше сos (х) или tg (x) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
В Паскале: 1. Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N. 2. Составить программу, которая определяет НОД и НОК двух чисел.
Ответы (1)