Задать вопрос
7 ноября, 23:57

В Паскале:

1. Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N.

2. Составить программу, которая определяет НОД и НОК двух чисел.

+5
Ответы (1)
  1. 8 ноября, 00:48
    0
    1)

    program gt;

    var n, s:integer;

    procedure summa (n:integer; var s:integer) ;

    begin

    s: = ((n+1) * n) div 2;

    writeln (s) ;

    end;

    begin

    read (n) ;

    summa (n, s) ;

    end.

    1.2)

    program gt2;

    var n, s:integer;

    function summa (n:integer) : integer;

    var s:integer;

    begin

    s: = ((n+1) * n) div 2;

    summa:=s;

    end;

    begin

    read (n) ;

    s:=summa (n) ;

    writeln (s) ;

    end.

    2) program gt;

    label 3,9;

    var m, n, q, r, a, b:longint;

    begin

    read (m, n) ;

    a:=m; b:=n;

    3:

    q:=m div n;

    r:=m mod n;

    if (r=0) then goto 9;

    m:=n;

    n:=r;

    goto 3;

    9:

    m: = (a*b) div n;

    writeln ('НОД=', n) ;

    writeln ('NOK=', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале: 1. Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N. 2. Составить программу, которая определяет НОД ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел: по формуле НОК (A, B) = (A*B) / НОД (A*B) (Определить процедуру, распознающую НОД двух чисел)
Ответы (1)
1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа: 28 15 10 Наибольшее число: 28 2) Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее
Ответы (1)