Задать вопрос
5 августа, 15:14

Дано натурольное четырехзначное число. Определите, будет ли произведение цифр этого числа кратно трем?

+5
Ответы (1)
  1. 5 августа, 17:10
    0
    Var a:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if (((a mod 10) * (a div 1000) * (a div 100 mod 10) * (a mod 100 div 10)) mod 3 = 0) then write ('произведение цифр этого числа кратно трём')

    else write ('произведение чисел не кратно трём')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натурольное четырехзначное число. Определите, будет ли произведение цифр этого числа кратно трем? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
Задача на Паскале. Дано число, если оно кратно 3 (трем) - увеличить его на 5, если кратно 2 (двум) - увеличить в 4 раза, если не кратно - увеличить на 1. * Использовать функцию "остаток от деления равен нулю".
Ответы (1)