Задать вопрос
11 сентября, 14:09

Дан массив целых чисел из 12 элементов. Поменять местами первый отрицательный с первым положительным.

+3
Ответы (1)
  1. 11 сентября, 14:59
    0
    Var a: array[1 ... 12] of integer;

    i, z: integer;

    f:boolean;

    begin

    for i:=1 to n do

    readln (a[i]) ;

    z:=a[1];

    f:=false;

    for i:=2 to 12 do

    if not (f) and a[i]*a[1] then begin

    a[1]:=a[i];

    a[i]:=z;

    f:=true;

    end;

    for i:=1 to 12 do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из 12 элементов. Поменять местами первый отрицательный с первым положительным. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1) Заполнить массив N чисел значениями и вывести на экран произведение чётных элементов массива. 2) Дан массив действительных чисел. Найти максимальный элемент среди отрицательных элементов и поменять его местами с минимальным положительным.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)