Задать вопрос
12 февраля, 11:35

Даны два натуральных числа. Определить в каком числе первая цифра больше?

написать программу

+5
Ответы (1)
  1. 12 февраля, 14:27
    0
    Var n, k:integer;

    begin

    writeln ('Введите 2 числа через пробел') ;

    readln (n, k) ;

    if (strToInt (intToStr (n) [1]) > strToInt (intToStr (k) [1])) then writeln ('У первого числа первая цифра больше') ;

    if (strToInt (intToStr (n) [1]) < strToInt (intToStr (k) [1])) then writeln ('У воторого числа первая цифра больше') ;

    if (strToInt (intToStr (n) [1]) = strToInt (intToStr (k) [1])) then writeln ('У первого числа и воторого числа первые цифры равны') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два натуральных числа. Определить в каком числе первая цифра больше? написать программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. даны два натуральных числа а и б требуется определить сумму чисел от а до б. 2. дано натуральное число а, требуется определить есть ли в этом числе цифра 3. 3. начальный вклад в банк составил а рублей. через сколько лет он станет больше б рублей.
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
Нарисуй в окне цепочку П из пяти цифр так, чтобы все пять утверждений были истенными: В цепочке П цифра 3 идет раньше цифры 9. В цепочке П цифра 2 идет позже цифры 6. В цепочке П цифра 6 идет раньше цифры 9. В цепочке П цифра 6 идет позже цифры 5.
Ответы (1)