Задать вопрос
4 апреля, 03:48

Помогите составить программу!) В "Pascal ABC"

В последовательности действительных чисел a1, а2, ..., аn есть только положительные и

отрицательные элементы. Вычислить произведение отрицательных элементов Р1 и произведе-

ние положительных элементов Р2. Сравнить модуль Р1 с модулем Р2 и указать, какое из

произведений по модулю больше.

+1
Ответы (1)
  1. 4 апреля, 04:06
    0
    var

    p1, p2, buf: real;

    n: byte;

    begin

    readln (n) ;

    for i: byte : = 1 to n do

    begin

    readln (buf) ;

    if (buf > 0) then

    if (p2 = 0) then

    p2 : = buf

    else

    p2 : = p2 * buf

    else

    if (p1 = 0) then

    p1 : = buf

    else

    p1 : = p1 * buf;

    end;

    writeln ('P1 = ', p1, #13, 'P2 = ', p2) ;

    if (abs (p1) > abs (p2)) then

    writeln ('|', p1, '| > |', p2, '|')

    else

    if (abs (p1) < abs (p2)) then

    writeln ('|', p1, '| < |', p2, '|')

    else

    writeln ('|', p1, '| = |', p2, '|')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу!) В "Pascal ABC" В последовательности действительных чисел a1, а2, ..., аn есть только положительные и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Pascal ABC. Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов, произведение и количество отрицательных элементов, произведение элементов до первого отрицательного.
Ответы (1)
Введите с клавиатуры одномерный массив А (N), элементами которого являются положительные и отрицательные целые числа. Подсчитайте произведение положительных элементов этого массива и количество отрицательных.
Ответы (1)
1. В последовательности чисел подсчитать произведение чисел, кратных 3. 2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных. 3.
Ответы (1)
Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)