Задать вопрос
24 февраля, 00:05

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.

3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

+5
Ответы (1)
  1. 24 февраля, 00:56
    0
    1)

    var n, i, p:longint; a:array[1 ... 100]of longint;

    begin

    read (n) ; p:=1;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    if a[i] mod 3=0 then p:=p*a[i];

    writeln (p) ;

    end.

    2)

    var n, i, s, p:longint; a:array[1 ... 100]of longint;

    begin

    read (n) ;

    p:=1; s:=0;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    if a[i]>0 then s:=s+a[i];

    for i:=1 to n do

    if a[i]<0 then p:=p*a[i];

    if p>s then writeln ('proizvedenie')

    else if p
    else writeln ('ravni') ;

    end.

    3)

    var n, f, i, o:longint; a:array[1 ... 100]of longint;

    begin

    read (n) ; f:=0;

    for i:=1 to n do

    read (a[i]) ;

    for i:=n downto 1 do begin

    if a[i]<0 then f:=f+1;

    if f=2 then begin o:=a[i]; break; end;

    end;

    writeln (o) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В последовательности чисел подсчитать произведение чисел, кратных 3. 2. В последовательности чисел сравнить, что больше сумма ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программы Введите несколько чисел. Найдите произведение чисел меньших 7. Введите несколько чисел. Найдите количество двузначных чисел. Введите несколько чисел.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
Напишите программы, для Паскаля. 1. Дано число Х. Определить положительное число или отрицательное. 2. Даны три целых числа. Определить количество положительных чисел. 3. Дано число Х. Определить чётное число или нечётное.
Ответы (2)