Задать вопрос
26 марта, 01:20

Решить задачу с while ...

Билет называют "счастливым", если в его номере сумма первых трех цифр равна сумме последних трех. Подсчитать число "счастливых" билетов и вывести их на экран (000000 до 999999).

+4
Ответы (1)
  1. 26 марта, 02:20
    0
    Var

    a, n, sum1, sum2, k: longint;

    begin

    a : = 100000;

    while a 999999 do

    begin

    sum1 : = 0; sum2 : = 0;

    n : = a div 1000;

    sum1 : = n div 100 + (n div 10) mod 10 + n mod 10;

    n : = a mod 1000;

    sum2 : = n div 10 + (n div 100) mod 10 + n mod 10;

    if sum1 = sum2 then

    begin

    writeln (a, ' - "счастливый" билет') ;

    k : = k + 1;

    end;

    a : = a + 1;

    end;

    writeln ('Всего ', k, ' таких билетов') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу с while ... Билет называют "счастливым", если в его номере сумма первых трех цифр равна сумме последних трех. Подсчитать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Шестизначный билет для проезда в любом транспортном средстве называется "счастливым по-ленинградски", если сумма первых трёх его цифр равна сумме трёх последних его цифр.
Ответы (2)
Трамвайный билет имеет шестизначный номер (от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если сумма первых трёх чисел равна сумме трёх других чисел. Через цикл whili, а также div mod
Ответы (1)
Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух последних.
Ответы (1)
С помошью циклов вывести на экран номера всех "счастливых" билетов из диапазона 000000 до 999999
Ответы (2)
Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет "счастливым", если сумма первых двух цифр его номера равна сумме последних двух цифр.
Ответы (1)