Задать вопрос
30 июля, 01:44

Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух последних.

+3
Ответы (1)
  1. 30 июля, 02:06
    0
    615 чисел.

    Вот программа на Паскале ABC по их вычислению:

    Program bilet;

    var i:integer;

    s:string;

    begin

    for i:=1000 to 9999 do begin

    s:=IntToStr (i) ;

    if StrToInt (s[1]) + StrToInt (s[2]) = StrToInt (s[3]) + StrToInt (s[4]) then writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Шестизначный билет для проезда в любом транспортном средстве называется "счастливым по-ленинградски", если сумма первых трёх его цифр равна сумме трёх последних его цифр.
Ответы (2)
Решить задачу с while ... Билет называют "счастливым", если в его номере сумма первых трех цифр равна сумме последних трех. Подсчитать число "счастливых" билетов и вывести их на экран (000000 до 999999).
Ответы (1)
Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет "счастливым", если сумма первых двух цифр его номера равна сумме последних двух цифр.
Ответы (1)
Определить, является ли "счастливым" трамвайный билет с шестизначным номером ("счастливым" считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). Составить блок-схему
Ответы (1)
Трамвайный билет имеет шестизначный номер (от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если сумма первых трёх чисел равна сумме трёх других чисел. Через цикл whili, а также div mod
Ответы (1)