Задать вопрос
13 марта, 05:13

2734

В стране кризис ... цены скачут ... Утром текущего дня цена плитки шоколада составляля P грв, но к вечеру его цена упала на 10%. За ночь котировки акций изменились и на утро следующего дня пришлось повысить цену на плитку шоколада на те же 10%. Сколько теперь стоит плитка шоколада?

Входные данные:

Во входном потоке задана цена плитки шоколада - вещественное число P.

Выходные данные:

Вывести единственное вещественное число с точностью два знака после запятой - нувую цену плитки шоколада.

Пример входного файла (input. txt) :

10

+2
Ответы (1)
  1. 13 марта, 06:48
    0
    Var

    p, r: real;

    f: Text;

    begin

    Assign (f, 'input. txt') ;

    Reset (f) ;

    read (f, p) ;

    Close (f) ;

    r : = p - 0.1 * p;

    r : = r + 0.1 * r;

    writeln (r:0:2)

    end.

    Тестовое решение:

    9.90
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2734 В стране кризис ... цены скачут ... Утром текущего дня цена плитки шоколада составляля P грв, но к вечеру его цена упала на 10%. За ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)