Задать вопрос
27 октября, 07:49

Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент.

+5
Ответы (1)
  1. 27 октября, 09:48
    0
    Program primer;

    const n=100;

    var a:array[1 ... n] of integer;

    i, max:integer;

    begin

    writeln ('vvedite massiv') ;

    for i:=1 to n do

    readln (' ', a[i]) ;

    max:=a[1];

    for i : = 1 to n do

    if (a[i]>a[1]) and (a[i]>0) then max:=a[i];

    writeln ('max=', max) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Дан одномерный целочисленный массив. Найти числа, которые при делении на 3 и 5 дают одинаковые остатки, посчитать их количество. Если такий чисел нет, то вывести соответствующее сообщение. 1. Д ан одномерный целочисленный массив.
Ответы (1)
Задания на PascalABC. Опишите как можно подробнее ход решения. №1. Дан одномерный целочисленный массив. Определить количество чисел, кратных 5. №2. Дан одномерный вещественный массив.
Ответы (1)