Задать вопрос
1 июля, 08:41

Задания на PascalABC. Опишите как можно подробнее ход решения.

№1. Дан одномерный целочисленный массив. Определить количество чисел, кратных 5.

№2. Дан одномерный вещественный массив. Найти сумму положительных элементов, произведение элементов, индексы которых четны.

№3. Составьте программу заполнения массива, не используя клавиатуру, числами: 2, 4, 6, 8, 10, 12, 14, 16, 18, 20.

Заранее благодарю.

+5
Ответы (1)
  1. 1 июля, 11:26
    0
    1) Program z1;

    var a: array [1 ... 1000] of integer;

    n, c, i: integer;

    begin

    readln (n) ;

    c : = 0;

    for i : = 1 to n do readln (a[i]) ;

    for i : = 1 to n do if (a[i] mod 5 = 0) then inc (c) ;

    writeln (c) ;

    readln;

    end.

    3) var a: array [1 ... 10] of integer;

    i: byte;

    begin

    for i:=1 to 10 do

    a [ i ] : = 2*i;

    begin

    for i:=1 to 10 do

    write (a[i]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задания на PascalABC. Опишите как можно подробнее ход решения. №1. Дан одномерный целочисленный массив. Определить количество чисел, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)