Задать вопрос
15 января, 18:03

Элементы заданной матрицы A (m, n) - целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.

+3
Ответы (1)
  1. 15 января, 19:44
    0
    Var

    a : array [1 ... 100,1 ... 100] of longint;

    n, m, i, j, sum, mnj : longint;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do read (a[i, j]) ;

    sum:=0;

    mnj : = 1;

    for i:=1 to n do

    for j:=1 to m do

    if (a[i, j] mod 3) = 0 or ((a[i, j] mod 2) = 0) then begin sum:=sum+a[i, j]) ; mnj:=mnj*a[i, j]; end;

    writeln (sum,' ', mnj) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Элементы заданной матрицы A (m, n) - целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Дан одномерный массив D, размерностью 20. Элементы массива - это целые числа из промежутка [0; 750]. Напишите программу в Паскале, вычисляющую количество элементов массива больших 500, которые кратны числу 15.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)