Задать вопрос
15 сентября, 02:31

Дан одномерный массив D, размерностью 20. Элементы массива - это целые числа из промежутка [0; 750]. Напишите программу в Паскале, вычисляющую количество элементов массива больших 500, которые кратны числу 15.

+1
Ответы (1)
  1. 15 сентября, 05:03
    0
    const

    n=20;

    var

    i, k, e:integer;

    a:array[1 ... n] of integer;

    begin

    Randomize;

    k:=0;

    for i:=1 to n do begin

    e:=random (750) ;

    a[i]:=e;

    if (e>500) and (e mod 15 = 0) then

    k:=k+1;

    write (e:4)

    end;

    writeln;

    writeln ('Найдено чисел: ', k) ;

    end.

    Тестовый пример:

    262 743 705 288 545 694 437 280 317 434 53 344 302 293 246 200 608 194 523 478

    Найдено чисел: 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив D, размерностью 20. Элементы массива - это целые числа из промежутка [0; 750]. Напишите программу в Паскале, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)