Задать вопрос
21 июля, 20:38

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]

Задана продолжительность некоторого события в секундах целым числом. Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.

Входные данные:

Во входном потоке задано единственное натуральное число T (T < 10000000)

Выходные данные:

Вывести три натуральных числа через пробел: часов, минут, секунд

Пример входного файла (input. txt) :

3666

+4
Ответы (1)
  1. 21 июля, 21:40
    0
    Var

    f: Text;

    T: longint;

    h, m, s, err: integer;

    c: string;

    begin

    Assign (f, 'input. txt') ;

    Reset (f) ;

    Readln (f, c) ;

    Val (c, T, err) ;

    Close (f) ;

    h : = T div 3600;

    T : = T mod 3600;

    m : = T div 60;

    s : = T mod 60;

    writeln (h, ' ', m, ' ', s)

    end.

    Тестовое решение:

    1 1 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%] Задана продолжительность некоторого события в секундах целым числом. Считая, что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Слон Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%] По заданным координатам слона и пешки определить, находится ли пешка под боем слона.
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)