Задать вопрос
25 апреля, 23:56

Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:

Вычислить

сумму положительных элементов матрицы А (10 х10), расположенных над главной

диагональю. Индекс номера строки i изменяется

от 1 до 9, а индекс номера столбца j изменяется от - i + 1

до 10.

+1
Ответы (1)
  1. 26 апреля, 00:51
    0
    Var a:array[1 ... 10,1 ... 10] of integer;

    i, j, sum, np: integer;

    begin

    for i:=1 to 10 do

    for j:=1 to 10 do readln (a[i, j]) ;

    sum:=0;

    for np:=1 to 9 do begin

    i:=np;

    for j:=1 to np do begin

    if a[i, j]>0 then sum:=sum+a[i, j];

    i:=i-1;

    end;

    end;

    writeln ('Сумма элементов, расположенных выше главной диагонали равна ', sum) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле: Вычислить сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Составить и отладить программу обработки матрицы размерности n*n. Выполнить программу для n=4. Подсчитать сумму элементов матрицы стоящих над главной диагональю в Pascal
Ответы (1)
Разработать алгоритм и программу решения задачи: найти сумму отрицательных элементов двумерного массива находящихся на главной диагонали матрицы размером 10 х10 (с вводом и выводом матрицы)
Ответы (1)
Написать программу в Паскале. Ввести матрицу. Найти сумму s1 положительных элементов и сумму s2 отрицательных элементов над и под главной диагональю. Если s1>s2, то 1-ую и последнюю строки заменить на s1, иначе 1-ый и последний столбец на s2.
Ответы (1)