Задать вопрос
3 июня, 09:05

Написать программу в Паскале.

Ввести матрицу. Найти сумму s1 положительных элементов и сумму s2 отрицательных элементов над и под главной диагональю. Если s1>s2, то 1-ую и последнюю строки заменить на s1, иначе 1-ый и последний столбец на s2. Вывести матрицу на печать.

+4
Ответы (1)
  1. 3 июня, 09:14
    0
    Const

    n = 3;

    k = 3;

    var

    i, j, s1, s2:integer;

    a:array[1 ... n, 1 ... k] of integer;

    begin

    s1:=0;

    s2:=0;

    for i:=1 to n do

    for j:=1 to k do

    begin

    Writeln ('Введите a[', i,',', j,']:') ;

    readln (a[i, j]) ;

    if (a[i, j]>0) and (ij) then s1:=s1+a[i, j];

    if (a[i, j]<0) and (ij) then s2:=s2+a[i, j];

    end;

    if s1>s2 then

    for j:=1 to k do

    begin

    a[1, j]:=s1;

    a[n, j]:=s1;

    end;

    if s2>=s1 then

    for i:=1 to n do

    begin

    a[i, 1]:=s2;

    a[i, k]:=s2;

    end;

    writeln ('Полученный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to k do

    write ('a[':4, i,',', j,']=', a[i, j]) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале. Ввести матрицу. Найти сумму s1 положительных элементов и сумму s2 отрицательных элементов над и под главной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Дана матрица. Вычислить сумму и число положительных элементов, находящихся под главной диагональю. Вывести матрицу, сумму и число.
Ответы (1)
Язык Pascal! Дан алгоритм: Подпрограмма 1) ввести натуральное число M, N 2) если M=N перейти к п. 5, иначе к следующему пункту 3) если M>N, то M:=M-N; иначе N:=N-M 4) перейти к п.
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)