Задать вопрос
2 декабря, 13:09

Дана матрица. Вычислить сумму и число положительных элементов, находящихся под главной диагональю. Вывести матрицу, сумму и число.

+5
Ответы (1)
  1. 2 декабря, 14:39
    0
    const N=4;

    var a:array[1 ... N, 1 ... N]of integer;

    i, j, s, k:integer;

    begin

    for i:=1 to N do for j:=1 to N do a[i, j]:=random (10) ;

    for i:=1 to N do begin for j:=1 to N do write (a[i, j],' ') ; if j=N then writeln; end;

    for i:=1 to N do

    for j:=1 to N do

    if (i>j) then begin inc (k) ; s:=s+a[i, j]; end;

    writeln (s,' ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица. Вычислить сумму и число положительных элементов, находящихся под главной диагональю. Вывести матрицу, сумму и число. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Написать программу в Паскале. Ввести матрицу. Найти сумму s1 положительных элементов и сумму s2 отрицательных элементов над и под главной диагональю. Если s1>s2, то 1-ую и последнюю строки заменить на s1, иначе 1-ый и последний столбец на s2.
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)