Задать вопрос
6 сентября, 19:21

Решить в паскале найти произведение цифр четырёхзначного числа

+4
Ответы (1)
  1. 6 сентября, 20:29
    0
    Var

    p: longint;

    k, m, n, i: integer;

    begin

    Write ('Введите целое четырехзначное число: ') ;

    Readln (n) ;

    n : = Abs (n) ; { вдруг отрицательное введут? }

    p : = 1;

    for i : = 1 to 4 do

    begin

    m : = n mod 10;

    n : = n div 10;

    p : = p * m

    end;

    Writeln ('Произведение цифр в числе равно ', p) ;

    end.

    Тестовое решение:

    Введите целое четырехзначное число: 1234

    Произведение цифр в числе равно 24
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в паскале найти произведение цифр четырёхзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Записать в Паскале. Найти произведение всех цифр заданного четырехзначного числа.
Ответы (1)
В Паскале. Найти произведение всех цифр заданного четырехзначного числа.
Ответы (1)
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
В паскале Составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр.
Ответы (1)