Задать вопрос
15 апреля, 20:18

В паскале

Составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр.

+2
Ответы (1)
  1. 15 апреля, 20:36
    0
    Var

    n, a, b, c, d, s, p: integer;

    begin

    Write ('Введите натуральное четырехзначное число: ') ;

    Readln (n) ;

    if (n > 9999) or (n < 1000) then Writeln ('Число должно быть четырехзначным')

    else begin

    a : = n div 1000; d : = n mod 10; n : = (n div 10) mod 100;

    b : = n div 10; c : = n mod 10;

    s : = a + b + c + d;

    p : = a * b * c * d;

    Writeln ('Сумма цифр равна ', s, ', а их произведение равно ', p)

    end

    end.

    Тестовое решение:

    Введите натуральное четырехзначное число: 2345

    Сумма цифр равна 14, а их произведение равно 120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В паскале Составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа 1) сумму и произведение его цифр; 2) число, образованное перестановкой цифр исходного числа.
Ответы (1)
Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (1)
Я писал программу в Паскале ABC для произвольного промежутка [a:b] и для произвольного количества случайных чисел.
Ответы (1)