Задать вопрос
12 сентября, 13:52

1. Вычислить

сумму первых N

слагаемых 12+22-32+42+52-62+ ... (каждое

третье слагаемое берется со знаком "минус").

1. Из N

целых чисел найти минимальное среди положительных и максимальное среди

отрицательных значений.

+2
Ответы (1)
  1. 12 сентября, 17:20
    0
    1)

    var

    b, c, n: integer;

    begin

    readln (n) ;

    c : = 12;

    for b : = 2 to n do

    if (b mod 2 = 0) then

    c : = c + (b * 10 + 2)

    else

    c : = c - (b * 10 + 2) ;

    writeln (c) ;

    end.

    2)

    var

    max, min, n, i, t: integer;

    begin

    readln (n) ;

    if (n = 0) then exit;

    readln (t) ;

    min : = 65536;

    max : = - 65536;

    for i : = 2 to n do

    begin

    readln (t) ;

    if ((t > 0) and (t < min)) then

    min : = t;

    if ((t max)) then

    max : = t;

    end;

    writeln (max, ' ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Вычислить сумму первых N слагаемых 12+22-32+42+52-62+ ... (каждое третье слагаемое берется со знаком "минус"). 1. Из N целых чисел найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
Написать программу на Паскале: Среди 10 целых положительных и отрицательных чисел: 1. Найти максимальное и минимальное значения. 2. Среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.
Ответы (2)