Задать вопрос
25 февраля, 08:29

Дано натуральное число b и n целых чисел. Верно ли, что сумма данных целых чисел не превышает b.

+3
Ответы (1)
  1. 25 февраля, 12:25
    0
    var

    b, n, s, a: integer;

    begin

    readln (b, n) ;

    for i: integer : = 1 to n do

    begin

    readln (a) ;

    s + = a;

    end;

    writeln (b > = s? 'Yes' : 'No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число b и n целых чисел. Верно ли, что сумма данных целых чисел не превышает b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Дано натуральное число N, последовательность целых чисел A1, A2, ... An. Составить программу, которая последовательно прибавляя членв последовательности, выводит результат, когда сумма впервые превышает число N.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Паскаль 1. Дано натуральное число N и N целых чисел, задаваемых пользователем. Определить, сколько среди этих N чисел двузначных. Массивы не использовать. 2. Дано натуральное число N и N целых трехзначных чисел, задаваемых пользователем.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)