Задать вопрос
23 февраля, 23:52

Дано натуральное число N, последовательность целых чисел A1, A2, ... An. Составить программу, которая последовательно прибавляя членв последовательности, выводит результат, когда сумма впервые превышает число N. Если сумма всех членов последовательности не превышает число N, выведите об этом сообщение

+2
Ответы (1)
  1. 24 февраля, 02:24
    0
    Const

    n = 5;

    var

    arr: array [1 ... n] of integer;

    i, N1, sum: integer;

    begin

    write ('N = ') ;

    readln (N1) ;

    for i : = 1 to n do

    begin

    write ('A[', i, '] = ') ;

    readln (arr[i]) ;

    end;

    i : = 1;

    sum : = 0;

    while (sum < = N1) and (i < = n) do

    begin

    sum : = sum + arr[i];

    i : = i + 1;

    end;

    if sum > N1 then

    writeln (sum)

    else

    writeln ('Summa not grether then N') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N, последовательность целых чисел A1, A2, ... An. Составить программу, которая последовательно прибавляя членв ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)