Задать вопрос
13 апреля, 04:14

Составить программу в паскале с использованием циклических операторов:

Среди всех чисел, меньших к (к<=999) указать те, сумма цифр которых равна даномучислу n

+3
Ответы (1)
  1. 13 апреля, 07:02
    0
    function sum (i, n: integer) : boolean;

    var

    a, b: integer;

    begin

    a : = i;

    repeat

    b : = b + a mod 10;

    a : = a div 10;

    until (a = 0) ;

    sum : = (b = n) ;

    end;

    var

    n, i, k: integer;

    begin

    readln (n, k) ;

    for i : = 1 to k do

    if sum (i, n) then

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале с использованием циклических операторов: Среди всех чисел, меньших к (к ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в паскале с использованием циклических операторов: найти все натуральные решения уравнения х^2+у^2=М, где М>0 задает пользователь
Ответы (1)
Составить программу в паскале с использованием циклических операторов: три приятеля математика были свидетелями дорожного происшествия. Номер машины (четырехзначный) ни один из них не запомнил.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)