Задать вопрос
2 мая, 15:59

Написать задачу перевода из 10 с. с. в 2 с. с. двумя способами:

1) функции

2) процедуры

+2
Ответы (1)
  1. 2 мая, 19:16
    0
    Function toBin (dec: integer) : string;

    var

    buf: integer;

    str: string;

    begin

    buf : = dec;

    repeat

    str : = concat (IntToStr (buf mod 2), str) ;

    buf : = buf div 2;

    until (buf = 0) ;

    toBin : = str;

    end;

    procedure toBin (dec: integer; var bin: string) ;

    var

    buf: integer;

    begin

    buf : = dec;

    repeat

    bin : = concat (IntToStr (buf mod 2), bin) ;

    buf : = buf div 2;

    until (buf = 0) ;

    end;

    var

    s: string;

    begin

    writeln (toBin (10)) ;

    toBin (10, s) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать задачу перевода из 10 с. с. в 2 с. с. двумя способами: 1) функции 2) процедуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Задачу решить двумя способами: с использованием подпрограммы-функции и подпрограммы-процедуры. Обязательно построение блок-схем алгоритмов! 1. Треугольник задан координатами своих вершин.
Ответы (1)
Написать подпрограмму, вычисляющую натуральную степень числа. паскаль написать программу на компьютере и проверить правильность работы Вашей процедуры/функции, в этом случае в основной программе должны быть реализованы ввод исходных данных и вызов
Ответы (1)
Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из промежутка [-20,20]. Каждый элемент массива заменить его кубом. Исходный и измененный массив вывести на экран.
Ответы (1)
1) назовите процедуры очистки экрана в текстовом и графическом режимах? 2) с помощью какой процедуры можно изменить цвет текста в графическом режиме?
Ответы (1)