Задать вопрос
20 марта, 11:39

Написать подпрограмму, вычисляющую натуральную степень

числа. паскаль

написать программу на компьютере и проверить правильность

работы Вашей процедуры/функции, в этом случае в основной программе

должны быть реализованы ввод исходных данных и вызов

процедуры/функции.

+3
Ответы (1)
  1. 20 марта, 14:47
    0
    Используем достаточно хорошо известный "индийский алгоритм" возведения в степень. Я не буду здесь его приводить из-за достаточно большого объема сопровождающих рассуждений; все легко находится в Интернет по фразе "индийский алгоритм возведения в степень".

    function Power (x: double; n: integer) : double;

    var

    p: double;

    flag: boolean;

    begin

    p : = 1; flag : = true;

    while flag do

    begin

    if odd (n) then p : = p * x;

    n : = n div 2;

    if n > 0 then x : = x * x else flag : = false

    end;

    power : = p

    end;

    var

    x: double;

    n: integer;

    begin

    Writeln ('Введите число и натуральную степень, в которую его надо возвести') ;

    Readln (x, n) ;

    Writeln ('Результат: ', Power (x, n))

    end.

    Тестовое решение:

    Введите число и натуральную степень, в которую его надо возвести

    3.6 11

    Результат: 1316217.03842267

    Точный результат равен 1316217.03842267136.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать подпрограмму, вычисляющую натуральную степень числа. паскаль написать программу на компьютере и проверить правильность работы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)