Задать вопрос
28 августа, 01:04

Составить программу для определения количества натуральных чисел из интервала от 100 до 500, сумма цифр которых равна 15

+5
Ответы (1)
  1. 28 августа, 01:28
    0
    Var a, b, c, d, e:integer;

    begin

    for a:=100 to 500 do begin

    b:=a mod 2; c:=a div 10 mod 10; d:=a div 100;

    e:=b+c;

    if e=15 then writeln (a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для определения количества натуральных чисел из интервала от 100 до 500, сумма цифр которых равна 15 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу с помощью Pascal ABC для определения количества натуральных чисел из интервала от 100 до 500, сумма цифр которых равна 15
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Я писал программу в Паскале ABC для произвольного промежутка [a:b] и для произвольного количества случайных чисел.
Ответы (1)
Дан интервал чисел [1, n]. Составить программу, которая чётные числа из этого интервала заменит на соответствующие кубы этих чисел, а все нечётные числа из этого интервала - заменит значением - 1.
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)