Задать вопрос
27 января, 05:01

Дан интервал чисел [1, n]. Составить программу, которая чётные числа из этого интервала заменит на соответствующие кубы этих чисел, а все нечётные числа из этого интервала - заменит значением - 1.

+5
Ответы (1)
  1. 27 января, 06:31
    0
    Program s;

    var

    a, b:integer;

    begin

    readln (b) ;

    for a:=1 to b do

    if a mod 2 = 0 then writeln (a*a) else writeln ('-1') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан интервал чисел [1, n]. Составить программу, которая чётные числа из этого интервала заменит на соответствующие кубы этих чисел, а все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1. Дан массив. Напечатать: а) Все четные 1. Дан массив. Напечатать: а) Все четные элементы б) Все элементы, оканчивающиеся нулем. 2. В массиве хранится информация о количестве осадков, выпавших каждый день января.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)