Задать вопрос
4 мая, 22:22

Для каждого четырёхзначного числа из диапазона от A до B включительно

(A
Например, если на вход программы подать A=1234 и B=1236, должно быть выведено 18.

Задача: Выполнить данную программу для A=1234 и B=9876. Это ответ №1.

Выполнить данную программу для A=4321 и B=5555. Это ответ №2.

Выполнить данную программу для A=2222 и B=7667. Это ответ №3.

В качестве окончательного результата найдите сумму всех трёх ответов.

+5
Ответы (1)
  1. 5 мая, 01:00
    0
    Program enot;

    Var i, a, b, n, f, g, v, p, s, c, j:integer;

    x: array[1 ... 9999] of integer;

    begin

    read (a, b) ;

    n:=b-a+1;

    for i: = a to b do

    begin

    x[i]:=i;

    for j: = a to b do

    begin

    c:=j div 10;

    V:=c mod 10;

    f:=c div 10;

    G: = f mod 10;

    p: = v*g;

    end;

    s:=s+p;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для каждого четырёхзначного числа из диапазона от A до B включительно (A ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Целое число было выбрано наугад из заданного диапазона чисел. Сообщение о выборе числа из какого диапазона несет наименьшее количество информации: a) от 12 до 76 b) от 100 до 133 c) от - 17 до 25 d) от - 32 до 0 e) от 12 до 34
Ответы (1)
Дан массив натуральных чисел заданных случайным образом из диапазона от 0 до 20 и число х из этого же диапазона. Длина массива равна N. Вставить число х после первого элемента кратного пяти
Ответы (2)
Составьте программу в Паскале Найдите сумму чисел, кратных 2 из диапазона от 1 до 38. Найдите произведение чисел, кратных 4 из диапазона от 2 до 25.
Ответы (1)
Вася выделил на экране программы Excel диапазон клеток высотой в 15 клеток и шириной в 700 клеток. Левый верхний угол выделенного диапазона находился в клетке E7. Напишите адрес клетки, являющейся правым нижним углом этого диапазона.
Ответы (1)