Задать вопрос
21 января, 00:03

Определить, принадлежит ли точка M с координатой x отрезку [a, b] числовой прямой. Значения x, a, b вводятся с клавиатуры.

+5
Ответы (1)
  1. 21 января, 02:56
    0
    Var

    a, x, b:real;

    begin

    readln (x, a, b) ;

    if a>b then

    if (x=b) then

    writeln ('Yes')

    else

    writeln ('No')

    else

    if (x=a) then

    writeln ('Yes')

    else

    writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, принадлежит ли точка M с координатой x отрезку [a, b] числовой прямой. Значения x, a, b вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Привет! Помогите решить задачи и написать программы в паскале: 1) Определить принадлежит ли некая точка с координатой х отрезку [a, b] числовой прямой. Значения а х b вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
С клавиатуры вводятся действительные числа x и y. Если x и y положительные, то каждое число удвоить; если оба значения принадлежит отрезку [-9; - 3], то оба значения увеличить в десять раз; в остальных случаях найти произведение
Ответы (1)