Задать вопрос
18 января, 08:38

Paskal.

Дана строка. Проверить правильность написания слов с ЖИ-ШИ. Если слово написано неправильно, то исправить его.

+3
Ответы (1)
  1. 18 января, 12:29
    0
    uses crt;

    var s, sc:string; i, k: integer;

    begin

    write ('s=') ;

    readln (s) ;

    for i:=1 to length (s) - 1 do

    begin

    sc:=copy (s, i, 2) ;

    if (sc='жы') or (sc='шы') then

    begin

    s[i+1]:='и';

    inc (k) ;

    end;

    end;

    if k=0 then writeln ('Ошибок не обнаружено') else begin writeln ('Обнаружены ошибки в количестве ', k,'. Ошибки исправлены: ') ; writeln (s) ; end; readkey end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Paskal. Дана строка. Проверить правильность написания слов с ЖИ-ШИ. Если слово написано неправильно, то исправить его. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)