Задать вопрос
22 июня, 01:49

Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.

+5
Ответы (1)
  1. 22 июня, 05:24
    0
    Var

    number1, number2, number3 : real;

    begin

    write ('Первое число: ') ;

    readln (number1) ;

    write ('Второе число: ') ;

    readln (number2) ;

    write ('Третье число: ') ;

    readln (number3) ;

    if (number1 > number3) then number1 : = number1 / 3;

    if (number3 > number2) then number3 : = number3 - number2;

    writeln ('Вывод') ;

    writeln ('Первое число: ', number1) ;

    writeln ('Второе число: ', number2) ;

    writeln ('Третье число: ', number3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! На языке Паскаль
Ответы (2)
Прием на работу идет на конкурентной основе, причем возраст сотрудников должен быть от 25 до 40 лет, а стаж работы не менее 5 лет. составьте программу отбора сотрудников.
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)