Задать вопрос
26 декабря, 05:06

Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! На языке Паскаль

+1
Ответы (2)
  1. 26 декабря, 07:14
    0
    Var

    a, b, c:real;

    begin

    Readln (a, b, c) ;

    if a > c then a: = a/2;

    if c > b then c: = c-b;

    Writeln (a, ' ', b, ' ', c) ;

    end.

    Пример:

    4 2 3

    2 2 1
  2. 26 декабря, 08:31
    0
    Var

    x, y, z:real;

    begin

    write ('Введите 1 число: ') ;

    readln (x) ;

    write ('Введите 2 число: ') ;

    readln (y) ;

    write ('Введите 3 число: ') ;

    readln (z) ;

    if x>z then x:=x/2;

    if z>y then z:=z-y;

    writeln ('1 число: ', x) ;

    writeln ('2 число: ', y) ;

    writeln ('3 число: ', z) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Прием на работу идет на конкурентной основе, причем возраст сотрудников должен быть от 25 до 40 лет, а стаж работы не менее 5 лет. составьте программу отбора сотрудников.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)