Задать вопрос
16 октября, 15:53

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, отличные от последнего слова.

+1
Ответы (1)
  1. 16 октября, 17:51
    0
    var

    s: string;

    begin

    readln (s) ;

    write (s. Split (' ') [0], ' ') ;

    foreach s1: string in s. Split (' ') do

    if (s1 s. Split (' ') [0]) then

    write (s1, ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, отличные от последнего слова. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Паскаль. Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу: удалить из слова все последующие вхождения первой буквы
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
С клавиатуры вводится строка, содержащая три слова, разделённые пробелом. Напишите программу, которая меняет местами второе и третье слово. Lazarus
Ответы (1)
Дана строка символов, груп символов разделенные пробелом (одним или несколькими) и не содержащие пробелолов внутри себя, будем называть словами.
Ответы (1)