Задать вопрос
10 сентября, 14:14

Паскаль.

Дана строка, состоящая из латинских букв. Последовательность подряд идущих букв образует слово. Между соседними словам - один пробел.

а) Напечатать текст, составленный из последних букв всех слов

б) напечатать эту же последовательность слов, удалив из нее слова-палиндромы (читающиеся одинаково слева на право и с право на лева)

+3
Ответы (1)
  1. 10 сентября, 15:52
    0
    var

    s: string;

    begin

    readln (s) ; / / s : = 'Привет дорогой мир шалаш кроет';

    write ('a) ') ;

    foreach s1: string in s. Split (' ') do

    write (s1. last ()) ;

    write (#13 + 'b) ') ;

    foreach s1: string in s. Split (' ') do

    begin

    var b: boolean : = true;

    var i: byte : = 1;

    while (i < = length (s1) / 2) and b do

    begin

    b : = (s1[i] = s1[length (s1) - i + 1]) ;

    Inc (i) ;

    end;

    if (not b) then

    write (s1, ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Дана строка, состоящая из латинских букв. Последовательность подряд идущих букв образует слово. Между соседними словам - один ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Ваня ведёт дневник, где в том числе отмечает, делал он зарядку в этот день или нет. Напишите программу, которая по собранной статистике сообщит, сколько последних дней подряд Ваня делал зарядку, а так же наибольшее число дней подряд когда он делал
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)