Задать вопрос
7 октября, 21:06

Сформировать двумерный массив а (3,4). Найти количество отрицательных нечетных элементов.

+2
Ответы (1)
  1. 7 октября, 23:59
    0
    Вот наполнение массива рандомом. Если нужно наполнение с клавиатуры, то вместо a[i, j]:=random (100) - 50; необходимо поставить read (a[i, j]) ;

    const n=3; m=4;

    var a:array[1 ... n, 1 ... m] of integer;

    var i, j, count:integer;

    begin

    count:=0;

    for i:=1 to n do begin

    for j:=1 to m do begin

    a[i, j]:=random (100) - 50;

    write (a[i, j]:3, ' ') ;

    end;

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to m do begin

    if (a[i, j]<0) and (a[i, j] mod 2 0) then count:=count+1;

    end;

    writeln ('Количество отрицательных нечетных элементов: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать двумерный массив а (3,4). Найти количество отрицательных нечетных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Заполнить двумерный массив с помощью датчика случ. чисел. Сформировать одномерный массив, закинуть произведение четных элементов по каждому столбику. Найти сумму элементов двумерного, для нечетных номеров столбика.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)