Задать вопрос
22 февраля, 09:10

В двумерном массиве размерностю nxm (n, m неболее 50), определить колличество строк, все элементы которых не более заданного числа x

+3
Ответы (1)
  1. 22 февраля, 12:00
    0
    Const

    n=50; m=50;

    var

    a:array[1 ... n, 1 ... m]of integer;

    i, j, k, x, h:integer;

    begin

    readln (x) ;

    for i:=1 to n do

    begin h:=0;

    writeln;

    for j:=1 to m do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    if a[i, j]<=x then

    h:=h+1

    end;

    if h=m then k:=k+1;

    end;

    writeln;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве размерностю nxm (n, m неболее 50), определить колличество строк, все элементы которых не более заданного числа x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми язык паскаль
Ответы (1)