Задать вопрос
8 апреля, 07:20

Дана непустая последовательность положительный целых чисел, за которой следует 0. Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале

+5
Ответы (1)
  1. 8 апреля, 10:52
    0
    Var

    x, sum:integer;

    begin

    repeat

    readln (x) ;

    if x mod 2 = 0 then

    sum:=sum+x;

    until x=0;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана непустая последовательность положительный целых чисел, за которой следует 0. Найти сумму всех четных чисел этой последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)
1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль
Ответы (1)
Написать программу в паскале, используя repeat until. Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней минимальную цифру.
Ответы (1)