Задать вопрос
27 июня, 14:20

Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу определяющую победителя после N бросков.

+3
Ответы (1)
  1. 27 июня, 14:54
    0
    Var n, i, sum1, sum2, buf: integer;

    begin

    writeln ('Введите количество бросков') ;

    readln (n) ;

    sum1 : = 0;

    sum2 : = 0;

    i : = 0;

    for i : = 1 to n do

    begin

    writeln ('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени А ') ;

    readln (buf) ;

    sum1 : = sum1 + buf;

    end;

    for i : = 1 to n do

    begin

    writeln ('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени B') ;

    readln (buf) ;

    sum2 : = sum2 + buf;

    end;

    if sum1 = sum2 then writeln ('Ничья') else

    if sum1 > sum2 then writeln ('Победил человек по имени А')

    else writeln ('Победил человек по имени B') ;

    end.

    Как то так ...
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу определяющую победителя после N бросков. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. Напишите программу, определяющую победителя
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)
Срочео помогите!1) Известны результаты трех участников по прыжкам в длину. Определить результат победителя. 2) Известны результаты забега на 100 (м) трех участников соревнований. Определить результат победителя. (языком паскаля)
Ответы (1)