Задать вопрос
24 марта, 17:50

Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. Напишите программу, определяющую победителя

+4
Ответы (1)
  1. 24 марта, 20:19
    0
    Var A, B:byte;

    S, Sa, Sb:integer;

    Begin

    WriteLn ('S = ') ; ReadLn (S) ;

    Repeat

    Write ('A = ') ; ReadLn (A) ;

    Sa:=Sa+A;

    Write ('B = ') ; ReadLn (B) ;

    Sb:=Sb+B;

    Until (Sa>=S) or (Sb>=S) ;

    if (A>B) then WriteLn ('Победил игрок A')

    else WriteLn ('Победил игрок B')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу определяющую победителя после N бросков.
Ответы (1)
1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу два камня или увеличить количество камней в куче в два раза.
Ответы (1)
Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу два камня или увеличить количество камней в куче в четыре раза.
Ответы (1)
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 2 камня, во второй - 3, в третьей - 4. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 3 камня, во второй - 1. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)