Задать вопрос
9 октября, 02:12

Дан целочисленный

двумерный массив 6x 10. Опишите на

русском языке и на языке программирования Паскаль алгоритм вычисления

произведения минимальных элементов из каждой строки. Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

+3
Ответы (1)
  1. 9 октября, 03:23
    0
    Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

    uses crt;

    const n=6; m=10;

    var i, j, min, ans:integer;

    a:array[1 ... n, 1 ... m] of integer;

    begin

    ans:=1;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (1,20) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    for i:=1 to n do

    begin

    min:=a[i, 1];

    for j:=2 to m do

    if a[i, j]
    min:=a[i, j];

    ans:=ans*min;

    end;

    writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный двумерный массив 6x 10. Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный прямоугольный массив 6x10. Опишите в программе "ПаскальАВС" алгоритм вычисления суммы минимальных элементов из каждой строки. Напечатать значение этой суммы. Предполагается, что в каждой строке минимальный элемент единственный.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Паскаль! Дан целочисленный квадратный массив 4 х 4. Найти строки с наибольшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.
Ответы (1)
Дан двумерный массив. Определить номер столбца, в котором расположен минимальный элемент четвертой строки массива. Если элементов с минимальным значением в этой строке несколько, то должен быть найден номер столбца самого левого из них. Паскаль.
Ответы (1)