Задать вопрос
17 июля, 16:25

дан целочисленный массив из 30 элементов. Вывести количество отрицательных, положительных и равных нулю элементов (массив записать в 1. txt)

+5
Ответы (2)
  1. 17 июля, 16:47
    0
    Program i5;

    var

    s, d, r, i: integer;

    a:array [1 ... 30] of integer;

    begin

    for i:=1 to 30 do

    readln (a[i]) ;

    s:=0;

    d:=0;

    r:=0;

    for i:=1 to 30 dot

    begin

    if a[i]<0 then

    s:=s+1;

    if a[i]>0 then

    d:=d+1;

    if a[i]=0 then

    r:=r+1;

    end;

    writeln (s,'_', d,'_', r) ;

    end.
  2. 17 июля, 16:49
    0
    Var t:text;

    a:array[1 ... 30] of integer;

    i, m, b, r:integer;

    begin

    assign (t,'output. txt') ;

    rewrite (t) ;

    for i:=1 to 30 do begin

    read (a[i]) ;

    if a[i]>0 then b+=1

    else if a[i]<0 then m+=1

    else r+=1;

    write (t, a[i],' ') ;

    end;

    write (m,' ', b,' ', r) ;

    close (t) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан целочисленный массив из 30 элементов. Вывести количество отрицательных, положительных и равных нулю элементов (массив записать в 1. txt) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
файл 1 txt хранится в папке txt 1 вложенной в папку txt находящейся на диске d каким является полный путь к файлу Варианты: 1) 1 2) / 1. txt 3) D:/ 4) / txt 5) txt
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Файл, полное имя которого было C:/doc/MyLetter. C сохранили в подкаталоге txt корневого каталога диска E. Каково полное имя сохраненного файла? 1) E:/txt/MyLetter. E 2) E:/txt/MyLetter. С 3) E:/txt/doc/MyLetter. С 4) E:/doc/txt/MyLetter. С
Ответы (1)