Задать вопрос
17 октября, 08:23

1) В массиве из 11 действительных чисел, введённых с клавиатуры, найти номер первого положительного элемента и выдать на экран этот элемент или сообщение о том, что в массиве положительных элементов нет.

прошу вас решите!

+5
Ответы (1)
  1. 17 октября, 09:36
    0
    Var a:array[1 ... 11] of real;

    t, i:integer;

    begin

    for i:=1 to 11 do

    read (a[i]) ;

    for i:=1 to 11 do

    if a[i]>0 then begin t:=i; break; end;

    if t0 then writeln (a[t])

    else writeln ('Not found') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) В массиве из 11 действительных чисел, введённых с клавиатуры, найти номер первого положительного элемента и выдать на экран этот элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На Паскаль 1. С клавиатуры вводится число. Осуществить линейный поиск элемента в массиве. Вывести номер элемента, равного данному, либо сообщение о том, что такого элемента в массиве нет. 2.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента массива; 2) сумму элементов массива, расположенных после первого положительного элемента.
Ответы (1)