Задать вопрос
24 ноября, 10:22

даны действительные положительные числа a, d, c, b вычислить существует ли прчмоугольник с такими сторонами

+5
Ответы (1)
  1. 24 ноября, 11:42
    0
    A, b, c, d-данные числа

    так как они действительные то хранить будем их в real

    так как у прямоугольника 2 противолежащие стороны равны то будем проверят случаи где a=b и c=d или a=c и b=d или a=d и b=c

    program chik;

    var a, b, c, d:real;

    begin

    read (a, b, c, d) ;

    if ((a=b) and (c=d)) or ((a=c) and (b=d)) or ((a=d) and (b=c)) then writeln ('да, такой прямоугольник существует') else writeln ('нет, прямоугольник с такими сторонами не существует') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны действительные положительные числа a, d, c, b вычислить существует ли прчмоугольник с такими сторонами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)
Составить программу в Паскале Даны действительные положительные числа x, y, z. выяснить существует ли треугольник с данными сторонами
Ответы (1)
Даны действительные положительные числа a, b, c, d. Выяснить, можно ли прямоугольник со сторонами a, b уместить внутри прямоугольника со сторонами c, d так, чтобы каждая из сторон одного прямоугольника была параллельна или перпендикулярна каждой
Ответы (1)
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)
Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)