Задать вопрос
28 июня, 16:43

Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.

+5
Ответы (1)
  1. 28 июня, 19:17
    0
    var

    a, b, c:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    write ('c = ') ; readln (c) ;

    if (a + b > c) and

    (a + c > b) and

    (b + c > a) then

    writeln ('YES')

    else

    writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)
Решите задачу в Python 3.3 Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)
Выходные данные Даны три натуральных числа a, b, c, записанные в отдельных строках. Определите, существует ли треугольник с такими сторонами (использовать неравенство треугольника Выходные данные Если треугольник существует, введите строку yes, если
Ответы (1)
Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. "Входные данные" Вводятся два числа. "Выходные данные" Выведите ответ на задачу.
Ответы (1)
Вводятся три целых числа. Выведите YES, если они расположены в порядке неубывания (каждое следующее больше либо равно предыдущего), NO иначе. Пример 1 Ввод Вывод 1 2 3 YES Пример 2 Ввод Вывод 1 3 2 NO Пример 3 Ввод Выво д 1 3 3 YES
Ответы (1)