Задать вопрос
7 декабря, 13:01

Дан массив из n элементов Определить сколько в нем двузначных элементов кратных 5.

+3
Ответы (2)
  1. 7 декабря, 13:16
    0
    Program gt;

    var n, a, p, k, q, i:integer;

    begin

    read (n) ;

    q:=0;

    for i:=1 to n do

    begin

    read (A) ;

    p:=a;

    if (a mod 5=0) then begin

    k:=0;

    while a>0 do

    begin

    a:=a div 10;

    k:=k+1;

    end;

    if (k=2) then q:=q+1;

    end;

    end;

    writeln (q) ;

    end.
  2. 7 декабря, 15:34
    0
    На Паскале:

    k:=0;

    for i:=1 to n do

    if (array[i] 9) and (array[i] mod 5 = 0) then k: = k+1;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов Определить сколько в нем двузначных элементов кратных 5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)