Задать вопрос
21 июня, 13:26

Заполните массив случайными числами и выполните реверс для части массива между элементами с индексами K и M (включая эти элементы).

+3
Ответы (1)
  1. 21 июня, 17:11
    0
    Var a:array[1 ... 10] of integer;

    i, m, k, p:integer;

    begin

    for i:=1 to 10 do begin

    a[i]:=random (-10,10) ;

    write (a[i]:3) ;

    end;

    writeln;

    read (k, m) ;

    for i:=k to (k+m) div 2 do begin

    p:=a[i];

    a[i]:=a[k+m-i];

    a[k+m-i]:=p;

    end;

    for i:=1 to 10 do

    write (a[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните массив случайными числами и выполните реверс для части массива между элементами с индексами K и M (включая эти элементы). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)