Задать вопрос
1 марта, 12:49

Найти сумму цифр целого положительного числа

+1
Ответы (1)
  1. 1 марта, 14:07
    0
    Begin

    write ('Введите целое положительное число m: ') ;

    var m : = ReadInteger;

    assert (m > 0) ;

    var s : = 0;

    while m > 0 do

    begin

    s + = m mod 10;

    m : = m div 10;

    end;

    writeln ('Сумма цифр числа m равна ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму цифр целого положительного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Числа 1) 2101. 2) - 2101. 3) F840 1. Получить двоичную форму внутреннего представления целого числа в 2-х байтовой ячейке. 2. Получить шестнадцатеричную форму внутреннего представления целого числа в 2-х байтовой ячейке. 3.
Ответы (1)